Application can not be started

Moderator: Michal Rok

Post Reply
Bob Orr
Premium User
Posts: 1
Joined: Sun Jul 21, 2013 3:49 pm

Application can not be started

Post by Bob Orr » Sun Jul 21, 2013 3:59 pm

I haven't used my premium in a while, and now it says application cannot be started. Did I miss an update along the way? I have vroute premium 2076. :?

Bob

User avatar
Michal Rok
Five Star Club
Posts: 2447
Joined: Wed Aug 31, 2005 4:23 pm

Re: Application can not be started

Post by Michal Rok » Wed Jul 24, 2013 4:20 am

hi

it's not caused by missing an update, but rather by accidental damage to .NET Configuration or Internet Explorer. Anyway, the cure is similar - could you try reinstalling using a fresh version downloaded from vroute.net?


Michal

Teasy
Premium User
Posts: 4
Joined: Thu Jul 25, 2013 7:01 am

Re: Application can not be started

Post by Teasy » Thu Jul 25, 2013 7:04 am

I´m a premium-member and i have the same problem!

Here is the error-log:

-------------------------------------------

PLATFORM VERSION INFO
Windows : 6.1.7601.65536 (Win32NT)
Common Language Runtime : 4.0.30319.1008
System.Deployment.dll : 4.0.30319.1 (RTMRel.030319-0100)
clr.dll : 4.0.30319.1008 (RTMGDR.030319-1000)
dfdll.dll : 4.0.30319.1 (RTMRel.030319-0100)
dfshim.dll : 4.0.31106.0 (Main.031106-0000)

SOURCES
Deployment url : file:///X:/vroute.premium/vroute.info%20premium_2_0_7_6.application

ERROR SUMMARY
Below is a summary of the errors, details of these errors are listed later in the log.
* Activation of X:\vroute.premium\vroute.info premium_2_0_7_6.application resulted in exception. Following failure messages were detected:
+ Store metadata "DeploymentSourceUri" is not valid.

COMPONENT STORE TRANSACTION FAILURE SUMMARY
No transaction error was detected.

WARNINGS
There were no warnings during this operation.

OPERATION PROGRESS STATUS
* [25.07.2013 08:59:02] : Activation of X:\vroute.premium\vroute.info premium_2_0_7_6.application has started.

ERROR DETAILS
Following errors were detected during this operation.
* [25.07.2013 08:59:02] System.Deployment.Application.DeploymentException (SubscriptionState)
- Store metadata "DeploymentSourceUri" is not valid.
- Source: System.Deployment
- Stack trace:
at System.Deployment.Application.ComponentStore.GetPropertyString(DefinitionAppId appId, String propName)
at System.Deployment.Application.ComponentStore.GetPropertyUri(DefinitionAppId appId, String propName)
at System.Deployment.Application.ComponentStore.GetSubscriptionStateInternal(DefinitionIdentity subId)
at System.Deployment.Application.SubscriptionStore.GetSubscriptionStateInternal(SubscriptionState subState)
at System.Deployment.Application.SubscriptionState.Validate()
at System.Deployment.Application.SubscriptionStore.CheckAndReferenceApplication(SubscriptionState subState, DefinitionAppId appId, Int64 transactionId)
at System.Deployment.Application.DownloadManager.DownloadDeploymentManifestDirectBypass(SubscriptionStore subStore, Uri& sourceUri, TempFile& tempFile, SubscriptionState& subState, IDownloadNotification notification, DownloadOptions options, ServerInformation& serverInformation)
at System.Deployment.Application.DownloadManager.DownloadDeploymentManifestBypass(SubscriptionStore subStore, Uri& sourceUri, TempFile& tempFile, SubscriptionState& subState, IDownloadNotification notification, DownloadOptions options)
at System.Deployment.Application.ApplicationActivator.PerformDeploymentActivation(Uri activationUri, Boolean isShortcut, String textualSubId, String deploymentProviderUrlFromExtension, BrowserSettings browserSettings, String& errorPageUrl)
at System.Deployment.Application.ApplicationActivator.ActivateDeploymentWorker(Object state)

COMPONENT STORE TRANSACTION DETAILS
No transaction information is available.

-------------------------

Please solve this problem.
thanks.

User avatar
Michal Rok
Five Star Club
Posts: 2447
Joined: Wed Aug 31, 2005 4:23 pm

Re: Application can not be started

Post by Michal Rok » Thu Jul 25, 2013 7:53 am

Please try installing the latest version from our website.

Michał

Teasy
Premium User
Posts: 4
Joined: Thu Jul 25, 2013 7:01 am

Re: Application can not be started

Post by Teasy » Thu Jul 25, 2013 8:42 am

Sorry, same error:

PLATFORM VERSION INFO
Windows : 6.1.7601.65536 (Win32NT)
Common Language Runtime : 4.0.30319.1008
System.Deployment.dll : 4.0.30319.1 (RTMRel.030319-0100)
clr.dll : 4.0.30319.1008 (RTMGDR.030319-1000)
dfdll.dll : 4.0.30319.1 (RTMRel.030319-0100)
dfshim.dll : 4.0.31106.0 (Main.031106-0000)

SOURCES
Deployment url : http://www.vroute.net/download.premium/ ... pplication
Server : lighttpd/1.4.26
Deployment Provider url : http://www.vroute.net/download.premium/ ... pplication
Application url : http://www.vroute.net/download.premium/ ... e.manifest
Server : lighttpd/1.4.26

IDENTITIES
Deployment Identity : vroute.info premium.application, Version=2.1.0.4, Culture=en, PublicKeyToken=6e4582eba90fbbe6, processorArchitecture=x86
Application Identity : vroute.info premium.exe, Version=2.1.0.4, Culture=en, PublicKeyToken=6e4582eba90fbbe6, processorArchitecture=x86, type=win32

APPLICATION SUMMARY
* Installable application.

ERROR SUMMARY
Below is a summary of the errors, details of these errors are listed later in the log.
* Activation of http://www.vroute.net/download.premium/vroute.info premium.application resulted in exception. Following failure messages were detected:
+ Store metadata "DeploymentSourceUri" is not valid.

COMPONENT STORE TRANSACTION FAILURE SUMMARY
No transaction error was detected.

WARNINGS
There were no warnings during this operation.

OPERATION PROGRESS STATUS
* [25.07.2013 10:41:07] : Activation of http://www.vroute.net/download.premium/vroute.info premium.application has started.
* [25.07.2013 10:41:07] : Processing of deployment manifest has successfully completed.
* [25.07.2013 10:41:07] : Installation of the application has started.
* [25.07.2013 10:41:08] : Processing of application manifest has successfully completed.
* [25.07.2013 10:41:14] : Found compatible runtime version 2.0.50727.
* [25.07.2013 10:41:14] : Detecting dependent assembly Sentinel.v3.5Client, Version=3.5.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a, processorArchitecture=msil using Sentinel.v3.5Client, Version=3.5.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a, processorArchitecture=msil.
* [25.07.2013 10:41:14] : Detecting dependent assembly System.Data.Entity, Version=3.5.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089, processorArchitecture=msil using System.Data.Entity, Version=3.5.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089, processorArchitecture=msil.
* [25.07.2013 10:41:14] : Detecting dependent assembly WindowsBase, Version=3.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35, processorArchitecture=msil using WindowsBase, Version=3.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35, processorArchitecture=msil.
* [25.07.2013 10:41:14] : Detecting dependent assembly System.Core, Version=3.5.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089, processorArchitecture=msil using System.Core, Version=3.5.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089, processorArchitecture=msil.
* [25.07.2013 10:41:14] : Detecting dependent assembly System.Data.Entity, Version=3.5.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089, processorArchitecture=msil using System.Data.Entity, Version=3.5.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089, processorArchitecture=msil.
* [25.07.2013 10:41:14] : Request of trust and detection of platform is complete.
* [25.07.2013 10:41:19] : Downloading of subscription dependencies is complete.
* [25.07.2013 10:41:19] : Commit of the downloaded application has started.

ERROR DETAILS
Following errors were detected during this operation.
* [25.07.2013 10:41:19] System.Deployment.Application.DeploymentException (SubscriptionState)
- Store metadata "DeploymentSourceUri" is not valid.
- Source: System.Deployment
- Stack trace:
at System.Deployment.Application.ComponentStore.GetPropertyString(DefinitionAppId appId, String propName)
at System.Deployment.Application.ComponentStore.GetPropertyUri(DefinitionAppId appId, String propName)
at System.Deployment.Application.ComponentStore.GetSubscriptionStateInternal(DefinitionIdentity subId)
at System.Deployment.Application.SubscriptionStore.GetSubscriptionStateInternal(SubscriptionState subState)
at System.Deployment.Application.SubscriptionState.Validate()
at System.Deployment.Application.ComponentStore.CollectCrossGroupApplications(Uri codebaseUri, DefinitionIdentity deploymentIdentity, Boolean& identityGroupFound, Boolean& locationGroupFound, String& identityGroupProductName)
at System.Deployment.Application.SubscriptionStore.CommitApplication(SubscriptionState& subState, CommitApplicationParams commitParams)
at System.Deployment.Application.ApplicationActivator.InstallApplication(SubscriptionState& subState, ActivationDescription actDesc)
at System.Deployment.Application.ApplicationActivator.PerformDeploymentActivation(Uri activationUri, Boolean isShortcut, String textualSubId, String deploymentProviderUrlFromExtension, BrowserSettings browserSettings, String& errorPageUrl)
at System.Deployment.Application.ApplicationActivator.ActivateDeploymentWorker(Object state)

COMPONENT STORE TRANSACTION DETAILS
No transaction information is available.

Teasy
Premium User
Posts: 4
Joined: Thu Jul 25, 2013 7:01 am

Re: Application can not be started

Post by Teasy » Fri Jul 26, 2013 4:00 pm

I need help from the developers. Enybody there?
I can´t use this product!

User avatar
Michal Rok
Five Star Club
Posts: 2447
Joined: Wed Aug 31, 2005 4:23 pm

Re: Application can not be started

Post by Michal Rok » Fri Jul 26, 2013 5:31 pm

Yes, I am here.

I'm afraid your .NET Framework installation is broken, or the store metadata is damaged.

Please try:
1) The instructions to clear your .NET app data - as described at http://www.vroute.net/content/view/71/41/
2) Reinstalling .NET Framework.


Michal

Teasy
Premium User
Posts: 4
Joined: Thu Jul 25, 2013 7:01 am

Re: Application can not be started

Post by Teasy » Sat Jul 27, 2013 7:47 am

Thanks Michal for your support.

This solution works fine for me!
But to move the "apps-folder" i must start the windows safe-mode. In the normal-mode doesn´t work this.

Post Reply