No routes after Mozilla Firefox installation

Problems? Bugs found? Questions? Please post here.

Moderator: Michal Rok

No routes after Mozilla Firefox installation

Postby hehu » Wed Dec 31, 2008 9:39 am

Hi,

searched the forum - found 1-2 people who seemed to have similar(?) problems, but could not resolve the problem with the answers given...

Problem:
Vroute starts up ok;
Switch to "route";
Get 2 error messages (see attachments);
The dropdown boxes are then empty (see attachment) and/or generate more (script?) errors.

I am running Windows XP Prof. (SP2), and had IE 6 running = Vroute worked just fine.
Then I installed Mozilla Firefox ver. 3.0.5 (en-US rv.1.9.0.5)

<--> that "broke" Vroute...;

I then deinstalled Vroute.
Installed Microsoft IE 7 (7.0.5730.13) and made sure that
http://www.vroute.net
https://www.vroute.net

was added to the "secure sites" in IE and that all scripting/pop-ups etc. is enabled; I also checked that the
MS Active X (MS XML DOM Documents 3.0, 4.0, 6.0) is available an running (in IE).

I then reinstalled vroute.
I played around with which browser is the default one.

However, vroute still has no routes for me.

A second machine (XP, IE6) works just fine under the very same network-conditions (wireless set-up @home).

Summary:
I am pretty convinced that the Mozilla Firefox installation (and/or its settings) took vroute out.
Any help to get me up running again would be appreciated!

Thanks up-front and a Very Good New 2009 to everyone!

Helge
Attachments
emptyDrpDwnBoxes.jpg
...resulting in empty drop-down boxes and/or more errors when trying other graphical widgets.
emptyDrpDwnBoxes.jpg (130.37 KiB) Viewed 7141 times
script-err2.jpg
2nd error msg.
script-err2.jpg (19.64 KiB) Viewed 7142 times
script-err1.jpg
this is the 1st error I get
script-err1.jpg (19.57 KiB) Viewed 7140 times
hehu
 
Posts: 4
Joined: Tue Dec 30, 2008 4:57 pm

Re: No routes after Mozilla Firefox installation

Postby Michal Rok » Wed Dec 31, 2008 1:20 pm

Quite strange indeed.

Since the vroute pages that you see are actually http://data.vroute.net and not www.vroute.net, could you please add just this address to secure sites?

If it won't help then I'm stuck. The line numbers in error messages indicate a gross problem with manipulating objects on screen - something that should almost certainly affect other screens in vroute. Is it just on the route page?


Michal
User avatar
Michal Rok
Five Star Club
 
Posts: 2431
Joined: Wed Aug 31, 2005 4:23 pm
Location: Warsaw, Poland

Re: No routes after Mozilla Firefox installation

Postby hehu » Tue Jan 06, 2009 5:44 pm

Michal Rok wrote:Quite strange indeed.

Since the vroute pages that you see are actually http://data.vroute.net and not http://www.vroute.net, could you please add just this address to secure sites?

If it won't help then I'm stuck. The line numbers in error messages indicate a gross problem with manipulating objects on screen - something that should almost certainly affect other screens in vroute. Is it just on the route page?


Michal


Hi Michal,

Thanks for replying so quickly -- I was busy flying thus my delayed response...

--> I added "http://data.vroute.net" and restart system.

Effect: None whatsoever for the reported error messages and effects (see original posting).

I have only problems with the "route" tab/button-view;
'info', 'online', 'book' all work 100%; including the interactive elements (calendar, drop-down lists etc.).

As you said, "game over" (?) -- to me it sounds a lot like something got awfully screwed within/during the Firefox installation that I do not reach anymore; I went through the registry, but could not find something obvious. But if this is not a "freak accident", there is the danger that we will see more systems running into problems when an XP-machine with IE goes into the Firefox world...

I will check back once here and see if someone has similar experiences or even a cure...

Thanks once more for your attempt to get me "out of the ditch"!

Kind Regards,
Helge
hehu
 
Posts: 4
Joined: Tue Dec 30, 2008 4:57 pm

Re: No routes after Mozilla Firefox installation

Postby Michal Rok » Tue Jan 06, 2009 6:13 pm

I'm pretty sure there's at least 100 vroute users moving from IE to Firefox every week, and you are unfortunately the only person who encountered this problem. Strange.

Can you try visiting http://demo.script.aculo.us/shop with IE to see if it works for you? It uses the same framework for manipulation of objects that did not work for you.

If this doesn't bring any clues i have one more thing we can try out...


Michal
User avatar
Michal Rok
Five Star Club
 
Posts: 2431
Joined: Wed Aug 31, 2005 4:23 pm
Location: Warsaw, Poland

Re: No routes after Mozilla Firefox installation

Postby hehu » Sat Jan 10, 2009 9:21 am

Michal Rok wrote:I'm pretty sure there's at least 100 vroute users moving from IE to Firefox every week, and you are unfortunately the only person who encountered this problem. Strange.

Can you try visiting http://demo.script.aculo.us/shop with IE to see if it works for you? It uses the same framework for manipulation of objects that did not work for you.

If this doesn't bring any clues i have one more thing we can try out...


Michal



Michal,

tested now as advised and works flawlessly, in IE and Firefox.
(no change to my Vroute problem)
Helge
hehu
 
Posts: 4
Joined: Tue Dec 30, 2008 4:57 pm

Re: No routes after Mozilla Firefox installation

Postby Michal Rok » Sat Jan 10, 2009 2:50 pm

OK, i'll send you a plugin by email that should help us move on...


Michal
User avatar
Michal Rok
Five Star Club
 
Posts: 2431
Joined: Wed Aug 31, 2005 4:23 pm
Location: Warsaw, Poland

CASE CLOSED! Re: No routes after Mozilla Firefox installat

Postby hehu » Sun Feb 08, 2009 9:33 am

Hi,
just a short status update & feedback: I got excellent and personal support by Michal Rok on this issue;

while I was examining the vroute system according to Michal's instruction today, the problem (stated above) has gone,
i.e., vroute works flawlessly for me in Mozilla Firefox now.

Thanks Michal for your dedicated assistance!

Helge
hehu
 
Posts: 4
Joined: Tue Dec 30, 2008 4:57 pm

Re: No routes after Mozilla Firefox installation

Postby Michal Rok » Sun Feb 08, 2009 10:12 am

Good to know :)


Michal
User avatar
Michal Rok
Five Star Club
 
Posts: 2431
Joined: Wed Aug 31, 2005 4:23 pm
Location: Warsaw, Poland

Re: No routes after Mozilla Firefox installation

Postby StoreMaster » Sun Feb 08, 2009 4:04 pm

I normally only use Firefox, just vroue is the exception.
Is there a way that vroute can also/only work within Firefox?
Thanks
Wolfgang
StoreMaster
Premium User
 
Posts: 5
Joined: Sat Oct 11, 2008 6:59 am
Location: LOWI

Re: No routes after Mozilla Firefox installation

Postby Michal Rok » Sun Feb 08, 2009 4:26 pm

No. It would practically mean re-writing half of the application.

By the way, is there any real difference between Firefox inside vroute and IE inside vroute, given that you cannot see the browser and that it only points at a predefined page?


Michal
User avatar
Michal Rok
Five Star Club
 
Posts: 2431
Joined: Wed Aug 31, 2005 4:23 pm
Location: Warsaw, Poland

Re: No routes after Mozilla Firefox installation

Postby StoreMaster » Sun Feb 08, 2009 4:45 pm

No, that makes no real difference. Its only a personal preference not to use IE.
If it means to rewrite the app its for sure not worth the work.
Thanks
Wolfgang
StoreMaster
Premium User
 
Posts: 5
Joined: Sat Oct 11, 2008 6:59 am
Location: LOWI

Re: No routes after Mozilla Firefox installation

Postby vsserafim » Fri Mar 13, 2009 1:19 pm

Hi folks,

I got the same problem here, but it happens as soon as I open vroute. I have exactly the same setup of our friend and the err is the same. Michal, could you send me that plugin?

My best regargs,

Vinícius
vsserafim
Premium User
 
Posts: 2
Joined: Fri Mar 13, 2009 1:09 pm

Re: No routes after Mozilla Firefox installation

Postby Michal Rok » Sun Mar 15, 2009 7:54 am

Hi Vinicius,

I'm not sure if the plugin solution is appropriate here (especially that it wasn't eventually used in Helge's case above). Please provide here some more information about the problem - i'd like to know which screen works and which does not. It might also help if you clear your Internet Explorer cache first (Tools | Internet Options | Delete | Delete Files).


Michal
User avatar
Michal Rok
Five Star Club
 
Posts: 2431
Joined: Wed Aug 31, 2005 4:23 pm
Location: Warsaw, Poland

Re: No routes after Mozilla Firefox installation

Postby vsserafim » Mon Mar 16, 2009 1:17 pm

Hi Michal,

In fact I already made the IE cache cleaning and, after that, I've had update my Windows XP. Now the error is a litte bit different: just when I start vroute I get an javascript error saying "Access Denied" and the address http://data.vroute.net/start.php.

I allready added http://*.vroute.net and https://*.vroute.net to me trusted sites list.

Thanks for your attention,

Vinícius
vsserafim
Premium User
 
Posts: 2
Joined: Fri Mar 13, 2009 1:09 pm

Re: No routes after Mozilla Firefox installation

Postby Michal Rok » Tue Mar 17, 2009 9:10 am

I'll send you a link by email to try out.


regards,

Michal
User avatar
Michal Rok
Five Star Club
 
Posts: 2431
Joined: Wed Aug 31, 2005 4:23 pm
Location: Warsaw, Poland

Next

Return to vroute info product support

Who is online

Users browsing this forum: Bing [Bot] and 1 guest